Błąd #4708

Błąd podczas instalacji biblioteki SFST

Added by Anonimowy Użytkownik over 6 years ago.

Status:NowyStart date:24 Apr 2013
Priority:WysokiDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Podczas instalacji biblioteki SFST (dostarczanej z Macą) pojawia się błąd:

"""
fst.C: In member function ‘void Transducer::enumerate_paths_node(Node*, std::vector<Label>&, NodeHashSet&, std::vector<Transducer*>&)’:
fst.C:445:27: error: redeclaration of ‘__gnu_cxx::hash_set<Node*, hashf, equalf>::iterator it’
NodeHashSet::iterator it=previous.insert(node).first;
^
fst.C:442:17: error: ‘ArcsIter it’ previously declared here
for( ArcsIter it(node->arcs()); it; it++ ) {
"""

Najpewniej wystarczy zmienić nazwę jednego z iteratorów.

Also available in: Atom PDF